Sin cambio en la forma de onda de 1.V a 2.V

Sin cambio en la forma de onda de 1.V a 2.V

Postby jaxllax » Wed Jun 05, 2019 12:23 pm

I have problems with the waveform of V / DIV = 1.V - V / DIV = 2.V, V / DIV = 2.V doubles the voltage,
I tried previous firmware version without favorable result

V / DIV = 2.V - SENSEL 3 = 0.06 V
V / DIV = 2 V - SENSEL 0 = 0.08 V

in V / DIV = 20.V the signal comes out down

V / DIV = 20.V - SENSEL 3 = 0.06 V
V / DIV = 20.V - SENSEL 2 = 0.07 V
V / DIV = 20.V - SENSEL 0 = 0.08 V

The remaining SENSEL of V / DIV = 2.V and V / DIV = 20.V are correct according to the SENSEL table

In the first image there is also a strange behavior in V / DIV = 10.V
Measures in GND
IMPUT = + 9.15
V + = + 8.32
AV + = + 6.74
V- = - 7.70
AV- = - 6.35
V1 = 0 V
V2 = 0V changes from (0V +) to (0V -) constantly
V3 = (- 0V) polymeter outputs the negative (-) constantly
V4 = + 1.40 V
V5 = Changing between (- 0.9V) and (- 1.00V)
V6 = + 5.45V
AIN = (GND = 0V) (DC = + 1.62V)
Plate version (C)
The DSO Shell is recently assembled, only used to calibrate
SMD components welded to the factory
Review with tin the components welded by me,
I checked values ​​of resistors that mount, everything seems correct,
inspection of smd components that come from the factory, welds in good condition
Test voltages in (GND) correspond to what is established in the manual
Excuse me because I do not write in English, I hope that with the translator and the images they can understand and help me with this problem
My experience in electronics does not understand why the oscilloscope has this behavior
Attachments
IMG_20190605_153142.jpg
IMG_20190605_140506.jpg
IMG_20190605_134644.jpg
IMG_20190605_134621.jpg
IMG_20190604_213412.jpg
IMG_20190604_213309.jpg
jaxllax
 
Posts: 14
Joined: Thu Jun 15, 2017 3:08 pm

Re: Sin cambio en la forma de onda de 1.V a 2.V

Postby jye1 » Sun Jun 09, 2019 3:13 pm

It looks the problem was SENSEL0 which was stuck at 0V. This explains the measurement results.
jye1
 
Posts: 1221
Joined: Wed Feb 20, 2013 4:58 pm

Re: Sin cambio en la forma de onda de 1.V a 2.V

Postby jaxllax » Mon Jun 10, 2019 2:21 pm

Does the STM32F103C8 have any damage?
SENSEL0 has communication with the pins 8-11-23-35-47 of (U1) STM32F103C8
SENSEL0 is connected to DGND
The condesadores that surround the STM32F103C8.
they do not present shorts
a cordial greeting
jaxllax
 
Posts: 14
Joined: Thu Jun 15, 2017 3:08 pm

Re: Sin cambio en la forma de onda de 1.V a 2.V

Postby jaxllax » Fri Jul 12, 2019 11:58 am

Definitivamente esta en mal estado el STM32F103C8, reemplace y lla funciona perfecto, según e podido deducir es un problema con la falta de protección en el conmutador GND y DC-AC sin hay una señal inyectada, en las actualizaciones de placa lla se resolvió este problema y se protegió con resistencia SENSEL0,
si tienen esta versión de tablero hay que intentar proteger la señal de entrada o en su defecto no conmutar a GND con una señal inyectada,esto es solo una idea que tengo de porque mi tablero dejo de funcionar, puedo estar equivocado lla que no soy experto en electrónica, un cordial saludo a todos y buen día
enlaces con mas información

viewtopic.php?t=1168&p=3803

idéntico problema con falla en soldadura macho que conectan la placa analógica
viewtopic.php?f=19&t=1936&p=6269&hilit=SENSEL0#p6269

correctos voltajes en las señales
viewtopic.php?f=19&t=1149&p=3866&hilit=SENSEL0#p3866
jaxllax
 
Posts: 14
Joined: Thu Jun 15, 2017 3:08 pm


Return to DSO Shell

Who is online

Users browsing this forum: No registered users and 2 guests