Page 1 of 1

062 LCD not lighting.

PostPosted: Fri Aug 19, 2016 12:23 am
by mwm
This is the one I posted pictures of in the "Counterfeit 062" thread. The voltages are:

D3: 10.3
D7: 0.3 ***
Q1 Left: 0.05
Q1 Top: 9.47
Q1 Bot: 9.51
C17: 0 ****
Q2 Top: 0 ****
Q2 Bot: 9.5 ****
U2: 4.3 ****
U1: 8.25 *****
C25: 0.6
C22: 2.6
TP1(?): 2.71
TP3:2.91 ****
TP4: 9.49
TP5: 5.02
TP6: 0.3 *****
TP7: 9.42
LCD Pin 18: 5.01
19: 5.02
20: 0
3: 5.00

I've marekd the ones that are clearly wrong with some *****'s. Nothing significant in the number. But it looks like something is dead on the board.

However, as noted in the counterfeit thread, the LCD module has no "signal" markings on it, which the instructions call for. I assumed the pin numbers were what that was, but looking at pictures with pin labels, this may not be the case. So the LCD may be on the wrong set of pins.

Re: 062 LCD not lighting.

PostPosted: Mon Aug 22, 2016 2:48 am
by jye1
Did you mean you didn't get the backlight on? The pin 19 and 20 of LCD are for backlight. You've got voltage on the correct. Please check any opens like trace broken. Otherwise the LCD was damaged inside. The backlight is simply an LED.

Re: 062 LCD not lighting.

PostPosted: Wed Aug 24, 2016 5:32 am
by mwm
Correct, the backlight doesn't come on. I confirmed the voltages on pins 19 and 20, and checked for open traces from them. Everything seems fine. This LCD module has always struck me as suspect, as it's missing the markings the assembly instructions refer to. Any chance of getting a replacement for it?