FG085 buttons not working

FG085 buttons not working

Postby robinhp » Wed Sep 09, 2015 11:27 am

I have seen this topic pass, but have not read a suitable solution.

After completing my FG085, bar the panels and BNC connector, connecting a 12 volts supply and switching power on:
- the LCD lights up and the power up sequence starts
- default settings are shown
- output is shown on connected oscilloscope
- none of the tact switches (buttons) have any effect

All switches are correctly mounted (twin slits side facing power connector and
- all switches tested and working (front panel not mounted)
- interconnections key pad tested and correct
- connections to respective diodes are correct

Any suggestions?
robinhp
 
Posts: 1
Joined: Sun Sep 06, 2015 3:40 pm
Location: Netherlands

Re: FG085 buttons not working

Postby tolcheevav » Fri Jan 08, 2016 10:29 pm

I have completly the same problem. Cannot understand what's went wrong... :cry:
tolcheevav
 
Posts: 1
Joined: Fri Jan 08, 2016 9:07 pm

Re: FG085 buttons not working

Postby jye1 » Sat Jan 09, 2016 12:41 pm

In 085 the button detection is by driving COL0 - COL5 low one by one and reading ROW0 - ROW3. If one or more these lines are bridged or shorted to something else it will cause detection error and consequently no button can be recognized. Please carefully check these line for any bridges or shorts. Check each pushbutton with ohm-meter to see if there is defective (like stuck inside).
jye1
 
Posts: 1221
Joined: Wed Feb 20, 2013 4:58 pm

Re: FG085 buttons not working

Postby swets » Thu Nov 29, 2018 9:37 pm

I have the same problem....


no buttons and no encoder... is that the same problem?
so know I know what to check....
swets
 
Posts: 1
Joined: Sun Jan 17, 2016 1:54 pm


Return to FG085

Who is online

Users browsing this forum: No registered users and 2 guests