[SOLVED] Vpos moving for measurements above 20ms

[SOLVED] Vpos moving for measurements above 20ms

Postby Leonardolb » Fri Aug 30, 2019 12:24 pm

I'm confused about this behavior, everything works fine until I switch for SEC/DIV above 20ms, as can be seen on the pictures.
If I try another Vpos alignment by pressing V/DIV for 3 sec, nothing changes, and this worng measurement keeps on its positions, if I return to values from 20ms to 10us, the 0V line returns to match with the arrow.
Attachments
20190830_091603_resized.jpg
With all values above 50ms, the line keeps static, worng measuring the voltages.
20190830_090201_resized.jpg
Right before switching to 50ms, a value increase appears.
20190830_090130_resized.jpg
Everything looks fine.
Last edited by Leonardolb on Tue Sep 10, 2019 11:46 am, edited 2 times in total.
Leonardolb
 
Posts: 6
Joined: Tue Aug 27, 2019 1:57 pm

Re: Vpos moving for measurings above 20ms

Postby Leonardolb » Fri Aug 30, 2019 12:30 pm

Another image.
Attachments
20190830_092002_resized.jpg
Changing the V/DIV value wont move the line.
Leonardolb
 
Posts: 6
Joined: Tue Aug 27, 2019 1:57 pm

Re: Vpos moving for measurements above 20ms

Postby Leonardolb » Mon Sep 09, 2019 7:25 pm

After a lot of research, couldn't find a fix for this problem.

An alternative was to find another firmware, wich led me to the famous Open DSO 150. After flashing it, all measurings are now correct (wich proves that the original firmware is defective). As a bonus, I have other options to play with the DSO, I recommend this ongoing work!

Attached is the .hex file, wich should be flashed as the original JYE Tech, like it is explained in the tutorial. This file is the pure compilation of michar71 work, just converted to .hex, wich can be flashed with an USB to UART TTL converter. Remember to hold the "OK" buttom on the first start up to reset all values to defaults.

Remember, do it if you know whats happening, I'm not responsible for any damage :)

Credits to michar71: https://github.com/michar71/Open-DSO-150
Attachments
open_dso_150_V3.1.rar
Open DSO 150 .hex Build
(52.91 KiB) Downloaded 42 times
Leonardolb
 
Posts: 6
Joined: Tue Aug 27, 2019 1:57 pm

Re: Vpos moving for measurements above 20ms

Postby jye1 » Tue Sep 10, 2019 8:41 am

Sorry for late response.

When timebase is set to values above 20ms the scope uses "rolling" display mode. That means the trace shifts from right to left endlessly. New date enters from the right end. If the current display window is not at the right end you won't see the new data right away. Instead you would see the earlier captured data. If you wait long enough you will see the new data shift into the display window from the right. At the time you first enter rolling mode the displayed data can be anything since it is irrelevant to the current input.

You can test with 50ms or 0.1s timebase since the trace will shift very fast at these settings.
jye1
 
Posts: 1220
Joined: Wed Feb 20, 2013 4:58 pm

Re: Vpos moving for measurements above 20ms

Postby Leonardolb » Tue Sep 10, 2019 11:41 am

Nice! Now I understood the process, maybe if I scrolled the horizontal bar all the way to the right, I should visualize the new incoming data and not the "garbage" of old measurements that was stored on the buffer.

If I return to the original firmware, I will check that, for now I will test the michar71, but thank you very much for the response! ;)
Leonardolb
 
Posts: 6
Joined: Tue Aug 27, 2019 1:57 pm


Return to DSO Shell

Who is online

Users browsing this forum: No registered users and 1 guest